1. Types of Routes - Static Routes and Dynamic Routes
Routing
is the process of selecting paths in a network along which to send network
traffic and route is the path to send the network traffic.
There
are two ways a router learn a route: static and dynamic. A static route is a
route that is manually configured on the router. Simply we can say a static
route is a route that is created manually by a network administrator. The
information about the networks that are directly connected to the active router
interfaces are added to the routing table initially and they are known as
connected routes. The second way that the router can learn static routes are by
configuring the routes manually.
Dynamic
routes are routes that a router learns by using a routing protocol. Routing
protocols will learn about routes from other neighbouring routers running the
same routing protocol. Dynamic routing protocols share network numbers a router
knows about and how to reach these networks. Through this sharing process, a
router can learn about all of the reachable network numbers in the network.
2. What is the difference between Routing Protocols and Routed
Protocols
While discussing
about protocols, two terms are commonly used: routing protocols and routed
protocols. A routing protocol learns routes for a routed protocol and routed
protocol carries user traffic such as e-mail, file transfers etc. IP, IPX and
Appletalk are the examples of Routed Protocols. An example of Routing Protocol
is OSPF (Open Shortest Path First).
Routed Protocol
|
Routing Protocols
|
IP
|
RIP, IGRP, OSPF, EIGRP
|
IPX
|
RIP, NLSP, EIGRP
|
Appletalk
|
RMTP, AURP, EIGRP
|
3.What is Autonomous System and Autonomous System Number
An
Autonomous System (AS) is a group of networks under a single administrative
control, which could be your company, a division within your company, or a
group of companies. An Interior Gateway Protocol (IGP) refers to a routing
protocol that handles routing within a single autonomous system. IGPs include
RIP, IGRP, EIGRP, and OSPF. An Exterior Gateway Protocol (EGP) handles routing
between different Autonomous Systems (AS). Border Gateway Protocol (BGP) is an
EGP. BGP is used to route traffic across the Internet backbone between
different autonomous systems.
Autonomous
System Numbers are 16-bit numbers, allowing 65,536 possible values. The
Autonomous System Number (ASN) value 0 is reserved, and the largest ASN value
65,535, is also reserved. The values, from 1 to 64,511, are available for use
in Internet routing, and the values 64,512 to 65,534 is designated for private
use. Routing protocols that understand the concept of an Autonomous System (AS)
are IGRP, EIGRP, OSPF, IS-IS, and BGP.
4.What is Administrative Distance
Administrative
Distance (AD) is a value that routers use in order to select the best path when
there are two or more different routes to the same destination from two
different routing protocols. Administrative Distance counts the reliability of
a routing protocol. Administrative Distance (AD) is a numeric value which can
range from 0 to 255. A smaller Administrative Distance (AD) is more trusted by
a router, therefore the best Administrative Distance (AD) being 0 and the
worst, 255.
Administrative Distance (AD)
|
Route Type
|
0
|
Connected interface
|
0 or 1
|
Static Route
|
90
|
Internal EIGRP Route (within the same AS)
|
100
|
IGRP Route
|
110
|
OSPF Route
|
115
|
IS-IS
|
120
|
RIP Route
|
255
|
Unknown Route
|
5.Introduction to Static Routes and Default Routes
What is a Static Route
A
static route is a route that is created manually by a network administrator.
Static routes are typically used in smaller networks. In static routing, the
routing table entries are populated manually by a network administrator.
The
opposite of a static route is a dynamic route. In dynamic routing, the the
routing table entries are populated with the help of routing protocols.
The
major advantages of static routing are reduced routing protocol router overhead
and reduced routing protocol network traffic. The major disadvantages of static
routing are network changes require manual reconfiguration in routers and
network outages cannot be automatically routed around. Also it is difficult to
configure static routing in a complex network.
What is a Default Route
A
Default Route (also known as the gateway of last resort) is a special type of
static route. Where a static route specifies a path a router should use to
reach a specific destination, a default route specifies a path the router should
use if it doesn’t know how to reach the destination.
Default
Route is the network route used by a router when there is no other known route
exists for a given IP datagram's destination address. All the IP datagrams with
unknown destination address are sent to the default route.
6.How to configure Static Routes and Default Routes
How to configure Static Routes
Static
Route can be configured by the following IOS commands.
•
Router(config)#ip route destination_network subnet_mask default_gateway
[administrative_distance] [permanent]
OR
•
Router(config)# ip route destination_network subnet_mask interface_to_exit
[administrative_distance] [permanent]
The
permanent keyword will keep the static route in the routing table even when the
interface the router uses for the static route fails.
Static Routing - Lab Practice
The
following diagram shows our lab setup. We have three routers, three switches
and three hosts connected as below. The host names, IP addresses and the
interfaces of the routers are shown in diagram. The IP addresses of the hosts
are also shown in the diagram.
If
you are not familiar with a router console connection, click the following link
to learn how to connect the serial port of your computer to router console
port.
Click
the following link to learn how to connect to the console port of the router if
there is no serial port in your computer.
Click
the following links to learn how to use HyperTerminal terminal emulator and
PuTTY terminal emulator to configure router.
Hostname and IP address configuration in Router01
Connect
to Router01 console and use the following IOS commands to configure host name
as Router01.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router01
Router01(config)#
Use
the following IOS commands to open the fast ethernet interface Fa0/0
configuration mode on Router01 and configure IP address as 172.16.0.1/16.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#interface fa0/0
Router01(config-if)#ip address 172.16.0.1 255.255.0.0
Router01(config-if)#no shutdown
Use
the following IOS commands to open the serial interface S0/0 configuration mode
on Router01 and configure IP address as 172.17.0.1/16. You have to set a clock
rate also using the "clock rate" command on S0/0 interface, since
this is the DCE side.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#interface s0/0
Router01(config-if)#clock rate 64000
Router01(config-if)#ip address 172.17.0.1 255.255.0.0
Router01(config-if)#no shutdown
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Hostname and IP address configuration in Router02
Connect
to Router02 console and use the following IOS commands to configure host name
as Router02.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router02
Router02(config)#
Use
the following IOS commands to open the fast ethernet interface Fa0/0
configuration mode on Router02 and configure IP address as 172.18.0.1/16.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface fa0/0
Router02(config-if)#ip address 172.18.0.1 255.255.0.0
Router02(config-if)#no shutdown
Use
the following IOS commands to open the serial interface S0/0 configuration mode
on Router02 and configure IP address as 172.17.0.2/16.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface s0/0
Router02(config-if)#ip address 172.17.0.2 255.255.0.0
Router02(config-if)#no shutdown
Use
the following IOS commands to open the serial interface S0/1 configuration mode
on Router02 and configure IP address as 172.19.0.1/16. You have to set a clock
rate also using the "clock rate" command on S0/1 interface, since
this is the DCE side.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface s0/1
Router02(config-if)#clock rate 64000
Router02(config-if)#ip address 172.19.0.1 255.255.0.0
Router02(config-if)#no shutdown
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Hostname and IP address configuration in Router03
Connect
to Router03 console and use the following IOS commands to configure host name
as Router03.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router03
Router03(config)#
Use
the following IOS commands to open the fast ethernet interface Fa0/0
configuration mode on Router03 and configure IP address as 172.20.0.1/16.
Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#interface fa0/0
Router03(config-if)#ip address 172.20.0.1 255.255.0.0
Router03(config-if)#no shutdown
Use
the following IOS commands to open the serial interface S0/1 configuration mode
on Router03 and configure IP address as 172.19.0.2/16.
Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#interface s0/1
Router03(config-if)#ip address 172.19.0.2 255.255.0.0
Router03(config-if)#no shutdown
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Static Routing configuration in Router01
Connect
to Router01 console and use the following IOS commands to configure static
routing in Router01. The "ip route" commands shown below states that
to reach 172.18.0.0/16, 172.19.0.0/16 and 172.20.0.0/16 networks, handover the
packets to the gateway ip address 172.17.0.2. The networks 172.16.0.0/16 and
172.17.0.0/16 are conneted directly to Router01.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#ip route 172.18.0.0 255.255.0.0 172.17.0.2
Router01(config)#ip route 172.19.0.0 255.255.0.0 172.17.0.2
Router01(config)#ip route 172.20.0.0 255.255.0.0 172.17.0.2
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router. To
view the routing table in Router01, run "show ip route" command in
Router01 as shown below.
Router01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 172.16.0.0/16 is directly connected, FastEthernet0/0
C 172.17.0.0/16 is directly connected, Serial0/0
S 172.18.0.0/16 [1/0] via 172.17.0.2
S 172.19.0.0/16 [1/0] via 172.17.0.2
S 172.20.0.0/16 [1/0] via 172.17.0.2
The
"S" character at the beginning of a line in routing table shows that
it is a static route and "C" character shows that it is a directly
connected network.
Static Routing configuration in Router02
Connect
to Router02 console and use the following IOS commands to configure static
routing in Router02. The "ip route" commands shown below states that
to reach 172.16.0.0/16 network, handover the packets to the gateway ip address
172.17.0.1 and to reach 172.20.0.0/16 network, handover the packets to the
gateway ip address 172.19.0.2. The networks 172.17.0.0/16, 172.18.0.0/16 and
172.19.0.0/16 are connected directly to Router02.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#ip route 172.16.0.0 255.255.0.0 172.17.0.1
Router02(config)#ip route 172.20.0.0 255.255.0.0 172.19.0.2
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router. To
view the routing table in Router02, run "show ip route" command in
Router02 as shown below.
Router02#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
S 172.16.0.0/16 [1/0] via 172.17.0.1
C 172.17.0.0/16 is directly connected, Serial0/0
C 172.18.0.0/16 is directly connected, FastEthernet0/0
C 172.19.0.0/16 is directly connected, Serial0/1
S 172.20.0.0/16 [1/0] via 172.19.0.2
The
"S" character at the beginning of a line in routing table shows that
it is a static route and "C" character shows that it is a directly
connected network.
Static Routing configuration in Router03
Connect
to Router03 console and use the following IOS commands to configure static
routing in Router03. The "ip route" commands shown below states that
to reach 172.16.0.0/16, 172.17.0.0/16 and 172.18.0.0/16 networks, handover the
packets to the gateway ip address 172.19.0.1. The networks 172.19.0.0/16 and
172.20.0.0/16 are conneted directly to Router03.
Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#ip route 172.16.0.0 255.255.0.0 172.19.0.1
Router03(config)#ip route 172.17.0.0 255.255.0.0 172.19.0.1
Router03(config)#ip route 172.18.0.0 255.255.0.0 172.19.0.1
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router. To
view the routing table in Router03, run "show ip route" command in
Router03 as shown below.
Router03#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
S 172.16.0.0/16 [1/0] via 172.19.0.1
S 172.17.0.0/16 [1/0] via 172.19.0.1
S 172.18.0.0/16 [1/0] via 172.19.0.1
C 172.19.0.0/16 is directly connected, Serial0/1
C 172.20.0.0/16 is directly connected, FastEthernet0/0
The
"S" character at the beginning of a line in routing table shows that
it is a static route and "C" character shows that it is a directly
connected network.
Verify the connectivity between networks using the ping command
To
verify the static routes which we have configured and the connectivity between
networks, run the ping command from Host01 (IP address: 172.16.0.10/16) to
Host03 (IP address: 172.20.0.10/16).
C:\>ping 172.20.0.10
Pinging 172.20.0.10 with 32 bytes of data:
Reply from 172.20.0.10: bytes=32 time=172ms TTL=125
Reply from 172.20.0.10: bytes=32 time=235ms TTL=125
Reply from 172.20.0.10: bytes=32 time=187ms TTL=125
Reply from 172.20.0.10: bytes=32 time=187ms TTL=125
Ping statistics for 172.20.0.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 172ms, Maximum = 235ms, Average = 195ms
The
ping reply from Host03 (IP address: 172.20.0.10/16) shows that the static
routes are configured well in three routers and there is network connectivity
between different networks.
How to configure Default Routes
Default
Route can be configured by the following IOS commands.
•
Router(config)#ip route 0.0.0.0 0.0.0.0 default_gateway
[administrative_distance] [permanent]
OR
•
Router(config)# ip route 0.0.0.0 0.0.0.0 interface_to_exit
[administrative_distance] [permanent]
7.What is Dynamic Routing and different types of Dynamic Routing
Static
routing allows routing tables in specific routers to be set up by the network
administrator. Dynamic routing use Routing Protocols that dynamically discover
network destinations and how to get to them. Dynamic routing allows routing
tables in routers to change if a router on the route goes down. Examples of
Routing Protocols are RIP, EIGRP and OSPF.
There
are three basic types of routing protocols.
Distance-vector Routing Protocols:
Distance-vector Routing Protocols use simple algorithms that calculate a
cumulative distance value between routers based on hop count.
Example:
RIP
Link-state Routing Protocols:
Link-state Routing Protocols use sophisticated algorithms that maintain a
complex database of internetwork topology.
Example:
OSPF
Hybrid Routing Protocols: Hybrid
Routing Protocols use a combination of distance-vector and link-state methods
that tries to incorporate the advantages of both and minimize their
disadvantages.
Example:
EIGRP
8.What is Routing Metric Value
If
the router has two types of routes, for the same network, the router chooses
Administrative Distance to choose the best one. But in some cases, there will
be two paths found by the same protocol, to the destination network. Here the
routing protocol will use routing metric value to find the best path.
Example:
RIP (Routing Information Protocol) uses hop count as the metric.
Following
are some of the factors to choose a best path to destination.
Metric
|
Routing
Protocols
|
Description
|
Bandwidth
|
IP EIGRP,
IP IGRP
|
The
bandwidth of the links in Kbps (T1=1,554)
|
Cost
|
IP OSPF
|
Measurement
in the inverse of the bandwidth of the links
|
Delay
|
IP EIGRP,
IP IGRP
|
Time it
takes to reach the destination
|
Hop count
|
IP RIP
|
How many
routers away from the destination
|
Load
|
IP EIGRP,
IP IGRP
|
The path
with the least utilization
|
Reliability
|
IP EIGRP,
IP IGRP
|
The path
with the least amount of errors or downtime
|
If
a router found multiple paths with the same administrative distance and metric
to a destination, load balancing can occur. Cisco IOS Software has a limit of
six equal-cost routes on the routing table, but some protocols set their own
limitations. For example, EIGRP allows up to four equal-cost routes.
9.What is Convergence of Routing Tables
In
dynamic routing, routing tables are created dynamically by obtaining the
network information from other routers. Routers in the network must be
constantly updated to changes in the network topology. Routes may be added or
removed, or routes may fail due to a break in the physical link.
When
a new link is added or a link fails or changes, updates are sent by routers
across the network that describe changes in the network topology. Other routers
in the network then runs a routing algorithm to recalculate routes and build
new routing tables based on the update information.
After
recalculation, all the routing tables have arrived at a common view of the
network topology. A converged network topology view means all the routers agree
on which links are up, which links are down, which links are running fastest
etc.
Convergence
time is the time which a group of routers reach the state of convergence.
Optimally the routing protocols must have fast convergence time.
10.Introduction to Distance Vector Routing Protocols
Distance
Vector protocols are the simplest amoung Routing Protocols. Distance vector
routing protocols use the distance and direction (vector) to find paths to destinations.
Distance Vector protocols use the Bellman-Ford algorithm for finding paths to
destinations.
Routers
running Distance Vector protocols learn who their neighbours are by listening
for routing broadcasts on their interfaces. Distance Vector protocols
periodically send local broadcasts (255.255.255.255) to share routing
information.
Distance
Vector algorithms pass routing table updates to their immediate neighbors in
all directions. At each exchange, the router increments the distance value received
for a route, thereby applying its own distance value to it. The routerwho
received this update again pass the updated table further outward, where
receiving routers repeat the process.
The
Distance Vector protocols do not check who is listening to the updates which
they sent and Distance Vector protocols broadcast the updates periodically even
if there is no change in the network topology.
Distance
Vector protocols are the simplest among three types of dynamic routing
protocols. They are easy to set-up and troubleshoot. They require less router
resources. They receive the routing update, increment the metric, compare the
result to the routes in the routing table, and update the routing table if
necessary
11.Introduction to Routing Information Protocol (RIP)
IP
RIP (Routing Information Protocol) comes in two different versions: 1 and 2.
Version 1 is a distance vector protocol (RFC 1058) and Version 2 is a hybrid
protocol (RFCs 1721 and 1722).
Routing Information Protocol Version 1 (RIPv1)
RIPv1
uses local broadcasts to share routing information. These updates are periodic
in nature, occurring, by default, every 30 seconds. To prevent packets from
circling around a loop forever, both versions of RIP solve counting to infinity
by placing a hop count limit of 15 hops on packets. Any packet that reaches the
sixteenth hop will be dropped. RIPv1 is a classful protocol. RIP supports up to
six equal-cost paths to a single destination. Equal-cost path are the paths
where the metric is same (Hop count).
Routing Information Protocol (RIPv2)
RIPv2
is a distance vector protocol with routing enhancements built into it, and it
is based on RIPV1. Therefore, it is commonly called a hybrid protocol.
RIPv2
uses multicasts instead of broadcasts. RIPv2 supports triggered updates. when a
change occurs, a RIPv2 router will immediately propagate its routing
information to its connected neighbours. RIPv2 is a classless protocol and it
supports variable-length subnet masking (VLSM).
Both
RIPv1 and RIPv2 uses hop count as the metric.
Differences between RIPv1 and RIPv2
RIPv1
•
Supports only classful routing (Does not support VLSM).
•
No authentication.
•
RIPv1 uses Broadcast.
RIPv2
•
Supports classless routing (Supports VLSM). RIPv2 incorporates the addition of
the network mask in the update to allow classless routing advertisements.
•
Authentication is available.
•
RIPv2 uses multi-cast instead of broadcast. multicast communication reduces the
burden on the network devices that do not need to listen to RIP updates.
11.How to configure Routing Information Protocol (RIP)
If
you are not familiar with Routing Information Protocol (RIP), click the
following link to view an introduction to Routing Information Protocol (RIP).
Routing Information Protocol (RIP) Configuration
Routing
Information Protocol (RIP) can be configured in a router using the following
IOS commands. The "version 2" IOS command specifies that we are using
RIPv2.
Router>enable
Router#configure terminal
Router(config)# router rip
Router(config-router)# version 2
Router(config-router)# network network_id
Routing Information Protocol (RIP) - Lab Practice
The
following diagram shows our lab setup. We have three routers, three switches
and three hosts connected as below. The host names, IP addresses and the
interfaces of the routers are shown in diagram. The IP addresses of the hosts
are also shown in the diagram.
If
you are not familiar with a router console connection, click the following link
to learn how to connect the serial port of your computer to router console
port.
Click
the following link to learn how to connect to the console port of the router if
there is no serial port in your computer.
Click
the following links to learn how to use HyperTerminal terminal emulator and
PuTTY terminal emulator to configure router.
Hostname and IP address configuration in Router01
Connect
to Router01 console and use the following IOS commands to configure host name
as Router01.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router01
Router01(config)#
Use
the following IOS commands to open the fast ethernet interface Fa0/0
configuration mode on Router01 and configure IP address as 172.16.0.1/16.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#interface fa0/0
Router01(config-if)#ip address 172.16.0.1 255.255.0.0
Router01(config-if)#no shutdown
Use
the following IOS commands to open the serial interface S0/0 configuration mode
on Router01 and configure IP address as 172.17.0.1/16. You have to set a clock
rate also using the "clock rate" command on S0/0 interface, since
this is the DCE side.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#interface s0/0
Router01(config-if)#clock rate 64000
Router01(config-if)#ip address 172.17.0.1 255.255.0.0
Router01(config-if)#no shutdown
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Hostname and IP address configuration in Router02
Connect
to Router02 console and use the following IOS commands to configure host name
as Router02.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router02
Router02(config)#
Use
the following IOS commands to open the fast ethernet interface Fa0/0
configuration mode on Router02 and configure IP address as 172.18.0.1/16.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface fa0/0
Router02(config-if)#ip address 172.18.0.1 255.255.0.0
Router02(config-if)#no shutdown
Use
the following IOS commands to open the serial interface S0/0 configuration mode
on Router02 and configure IP address as 172.17.0.2/16.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface s0/0
Router02(config-if)#ip address 172.17.0.2 255.255.0.0
Router02(config-if)#no shutdown
Use
the following IOS commands to open the serial interface S0/1 configuration mode
on Router02 and configure IP address as 172.19.0.1/16. You have to set a clock
rate also using the "clock rate" command on S0/1 interface, since
this is the DCE side.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface s0/1
Router02(config-if)#clock rate 64000
Router02(config-if)#ip address 172.19.0.1 255.255.0.0
Router02(config-if)#no shutdown
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Hostname and IP address configuration in Router03
Connect
to Router03 console and use the following IOS commands to configure host name
as Router03.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router03
Router03(config)#
Use
the following IOS commands to open the fast ethernet interface Fa0/0 configuration
mode on Router03 and configure IP address as 172.20.0.1/16.
Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#interface fa0/0
Router03(config-if)#ip address 172.20.0.1 255.255.0.0
Router03(config-if)#no shutdown
Use
the following IOS commands to open the serial interface S0/1 configuration mode
on Router03 and configure IP address as 172.19.0.2/16.
Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#interface s0/1
Router03(config-if)#ip address 172.19.0.2 255.255.0.0
Router03(config-if)#no shutdown
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Routing Information Protocol Version 2 (RIPv2) configuration in
Router01
Connect
to Router01 console and use the following IOS commands to configure Routing
Information Protocol Version 2 (RIPv2) in Router01. Please refer the beginning
of this lesson to view the Routing Information Protocol Version 2 (RIPv2)
configuration IOS commands.
Using
the IOS "network" command, as shown below, we specify only the
directly connected networks of this router.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#router rip
Router01(config-router)#version 2
Router01(config-router)#network 172.16.0.0
Router01(config-router)#network 172.17.0.0
Router01(config-router)#exit
Router01(config)#exit
Router01#
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Routing Information Protocol Version 2 (RIPv2) configuration in
Router02
Connect
to Router02 console and use the following IOS commands to configure Routing
Information Protocol Version 2 (RIPv2) in Router02. Please refer the beginning
of this lesson to view the Routing Information Protocol Version 2 (RIPv2)
configuration IOS commands.
Using
the IOS "network" command, as shown below, we specify only the
directly connected networks of this router.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#router rip
Router02(config-router)#version 2
Router02(config-router)#network 172.17.0.0
Router02(config-router)#network 172.18.0.0
Router02(config-router)#network 172.19.0.0
Router02(config-router)#exit
Router02(config)#exit
Router02#
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Routing Information Protocol Version 2 (RIPv2) configuration in
Router03
Connect
to Router03 console and use the following IOS commands to configure Routing
Information Protocol Version 2 (RIPv2) in Router03. Please refer the beginning
of this lesson to view the Routing Information Protocol Version 2 (RIPv2)
configuration IOS commands.
Using
the IOS "network" command, as shown below, we specify only the
directly connected networks of this router.
Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#router rip
Router03(config-router)#version 2
Router03(config-router)#network 172.19.0.0
Router03(config-router)#network 172.20.0.0
Router03(config-router)#exit
Router03(config)#exit
Router03#
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
How to view the routing table in Router01
After
the network is converged after the initial configuration and Routing
Information Protocol Version 2 (RIPv2) configuration, we can use the "show
ip route" to view the routing table in Router01, as shown below.
Router01>enable
Router01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 172.16.0.0/16 is directly connected, FastEthernet0/0
C 172.17.0.0/16 is directly connected, Serial0/0
R 172.18.0.0/16 [120/1] via 172.17.0.2, 00:00:22, Serial0/0
R 172.19.0.0/16 [120/1] via 172.17.0.2, 00:00:22, Serial0/0
R 172.20.0.0/16 [120/2] via 172.17.0.2, 00:00:22, Serial0/0
The
"R" character at the beginning of a line in routing table shows that
it is a route discovered by Routing Information Protocol Version 2 (RIPv2) and
"C" character shows that it is a directly connected network.
How to view the routing table in Router02
When
the network is converged after the initial configuration and Routing
Information Protocol Version 2 (RIPv2) configuration, we can use the "show
ip route" to view the routing table in Router02, as shown below.
Router02>enable
Router02#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
R 172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:07, Serial0/0
C 172.17.0.0/16 is directly connected, Serial0/0
C 172.18.0.0/16 is directly connected, FastEthernet0/0
C 172.19.0.0/16 is directly connected, Serial0/1
R 172.20.0.0/16 [120/1] via 172.19.0.2, 00:00:20, Serial0/1
The
"R" character at the beginning of a line in routing table shows that
it is a route discovered by Routing Information Protocol Version 2 (RIPv2) and
"C" character shows that it is a directly connected network.
How to view the routing table in Router03
When
the network is converged after the initial configuration and Routing
Information Protocol Version 2 (RIPv2) configuration, we can use the "show
ip route" to view the routing table in Router03, as shown below.
Router03>enable
Router03#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
R 172.16.0.0/16 [120/2] via 172.19.0.1, 00:00:02, Serial0/1
R 172.17.0.0/16 [120/1] via 172.19.0.1, 00:00:02, Serial0/1
R 172.18.0.0/16 [120/1] via 172.19.0.1, 00:00:02, Serial0/1
C 172.19.0.0/16 is directly connected, Serial0/1
C 172.20.0.0/16 is directly connected, FastEthernet0/0
The
"R" character at the beginning of a line in routing table shows that
it is a route discovered by Routing Information Protocol Version 2 (RIPv2) and
"C" character shows that it is a directly connected network.
Verify the connectivity between networks using the ping command
To
verify the Routing Information Protocol Version 2 (RIPv2) routes and the
connectivity between networks, run the ping command from Host01 (IP address:
172.16.0.10/16) to Host03 (IP address: 172.20.0.10/16).
C:\>ping 172.20.0.10
Pinging 172.20.0.10 with 32 bytes of data:
Reply from 172.20.0.10: bytes=32 time=172ms TTL=125
Reply from 172.20.0.10: bytes=32 time=188ms TTL=125
Reply from 172.20.0.10: bytes=32 time=157ms TTL=125
Reply from 172.20.0.10: bytes=32 time=188ms TTL=125
Ping statistics for 172.20.0.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 157ms, Maximum = 188ms, Average = 176ms
The
ping reply from Host03 (IP address: 172.20.0.10/16) shows that the Routing
Information Protocol Version 2 (RIPv2) is configured well in three routers and
there is network connectivity between different networks.
12.Introduction to Interior Gateway Routing Protocol (IGRP)
The
Interior Gateway Routing Protocol (IGRP) is a Cisco-proprietary routing
protocol for IP.
Some
of the features ifInterior Gateway Routing Protocol (IGRP) are
•
Interior Gateway Routing Protocol (IGRP) uses a sophisticated metric based on
bandwidth and delay.
•
Interior Gateway Routing Protocol (IGRP) uses triggered updates to speed-up
convergence.
•
Interior Gateway Routing Protocol (IGRP) supports unequal-cost load balancing
to a single destination.
Interior
Gateway Routing Protocol (IGRP) uses bandwidth, delay, reliability, load, to
find the metric value. By default, the algorithm uses only bandwidth and delay,
but the other metric components can be enabled. IGRP uses bandwidth, delay,
reliability, load, and MTU to find the metric value. By default, the algorithm
uses only bandwidth and delay, but the other metric components can be enabled.
The
following formula is used to calculate the composite metric of IGRP.
Metric
= [K1 * Bandwidth + (K2 * Bandwidth)/ (256-Load) + K3*Delay] * [K5/(Reliability
+ K4)]
The
default constant values are K1 = K3 = 1 and K2 = K4 = K5 = 0.
If
K5 = 0, the [K5/ (reliability + K4)] term is not used. So, given the default
values for K1 through K5, the composite metric calculation used by IGRP reduces
to Metric = Bandwidth + Delay.
•
To find the bandwidth value, find the smallest of all the bandwidths in Kbps
from outgoing interfaces and divide 10,000,000 by that number.
•
Reliability and load are measured 1–255. A reliability of 1 is least reliable,
while 255 is most reliable. A load of 1 is least utilized, while 255 is 100
percent utilized. The MTU refers to the size of the frame. If a route has lower
metric value, then that route is preferred.
•
In order to find the delay, add all of the delays (in microseconds) from the
outgoing interfaces and divide this number by 10. (The delay is in tenths of
microseconds.)
13.How to configure Interior Gateway Routing Protocol (IGRP)
If
you are not familiar with Interior Gateway Routing Protocol (IGRP), click the
following link to view an introduction to Interior Gateway Routing Protocol
(IGRP).
Interior Gateway Routing Protocol (IGRP) Configuration
Interior
Gateway Routing Protocol (IGRP) can be configured in a router using the
following IOS commands. If you have a new router with a latest IOS release, you
may not find Interior Gateway Routing Protocol (IGRP) configuration commands
because Interior Gateway Routing Protocol (IGRP) is removed from new IOS
releases.
Router(config)# router igrp ASN
Router(config-router)# network Network_ID
ASN
in the above IOS command stands for Autonomous System Number.
Interior Gateway Routing Protocol (IGRP) - Lab Practice
The
following diagram shows our lab setup. We have three routers, three switches
and three hosts connected as below. The host names, IP addresses and the
interfaces of the routers are shown in diagram. The IP addresses of the hosts
are also shown in the diagram.
If
you are not familiar with a router console connection, click the following link
to learn how to connect the serial port of your computer to router console
port.
Click
the following link to learn how to connect to the console port of the router if
there is no serial port in your computer.
Click
the following links to learn how to use HyperTerminal terminal emulator and
PuTTY terminal emulator to configure router.
Hostname and IP address configuration in Router01
Connect
to Router01 console and use the following IOS commands to configure host name
as Router01.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router01
Router01(config)#
Use
the following IOS commands to open the fast ethernet interface Fa0/0
configuration mode on Router01 and configure IP address as 172.16.0.1/16.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#interface fa0/0
Router01(config-if)#ip address 172.16.0.1 255.255.0.0
Router01(config-if)#no shutdown
Use
the following IOS commands to open the serial interface S0/0 configuration mode
on Router01 and configure IP address as 172.17.0.1/16. You have to set a clock
rate also using the "clock rate" command on S0/0 interface, since
this is the DCE side.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#interface s0/0
Router01(config-if)#clock rate 64000
Router01(config-if)#ip address 172.17.0.1 255.255.0.0
Router01(config-if)#no shutdown
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Hostname and IP address configuration in Router02
Connect
to Router02 console and use the following IOS commands to configure host name
as Router02.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router02
Router02(config)#
Use
the following IOS commands to open the fast ethernet interface Fa0/0
configuration mode on Router02 and configure IP address as 172.18.0.1/16.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface fa0/0
Router02(config-if)#ip address 172.18.0.1 255.255.0.0
Router02(config-if)#no shutdown
Use
the following IOS commands to open the serial interface S0/0 configuration mode
on Router02 and configure IP address as 172.17.0.2/16.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface s0/0
Router02(config-if)#ip address 172.17.0.2 255.255.0.0
Router02(config-if)#no shutdown
Use
the following IOS commands to open the serial interface S0/1 configuration mode
on Router02 and configure IP address as 172.19.0.1/16. You have to set a clock
rate also using the "clock rate" command on S0/1 interface, since
this is the DCE side.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface s0/1
Router02(config-if)#clock rate 64000
Router02(config-if)#ip address 172.19.0.1 255.255.0.0
Router02(config-if)#no shutdown
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Hostname and IP address configuration in Router03
Connect
to Router03 console and use the following IOS commands to configure host name
as Router03.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router03
Router03(config)#
Use
the following IOS commands to open the fast ethernet interface Fa0/0
configuration mode on Router03 and configure IP address as 172.20.0.1/16.
Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#interface fa0/0
Router03(config-if)#ip address 172.20.0.1 255.255.0.0
Router03(config-if)#no shutdown
Use
the following IOS commands to open the serial interface S0/1 configuration mode
on Router03 and configure IP address as 172.19.0.2/16.
Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#interface s0/1
Router03(config-if)#ip address 172.19.0.2 255.255.0.0
Router03(config-if)#no shutdown
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Interior Gateway Routing Protocol (IGRP) configuration in Router01
Connect
to Router01 console and use the following IOS commands to configure Interior
Gateway Routing Protocol (IGRP) in Router01. Please refer the beginning of this
lesson to view the Interior Gateway Routing Protocol (IGRP) configuration IOS
command.
In
the IOS "network" command, shown below, we specify only the directly
connected networks of this router.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)# router igrp 1
Router01(config-router)# network 172.16.0.0
Router01(config-router)# network 172.17.0.0
Router01(config-router)#exit
Router01(config)#exit
Router01#
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Interior Gateway Routing Protocol (IGRP) configuration in Router02
Connect
to Router02 console and use the following IOS commands to configure Interior
Gateway Routing Protocol (IGRP) in Router02. Please refer the beginning of this
lesson to view the Interior Gateway Routing Protocol (IGRP) configuration IOS
command.
In
the IOS "network" command, shown below, we specify only the directly
connected networks of this router.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)# router igrp 1
Router02(config-router)# network 172.17.0.0
Router02(config-router)# network 172.18.0.0
Router02(config-router)# network 172.19.0.0
Router02(config-router)#exit
Router02(config)#exit
Router02#
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Interior Gateway Routing Protocol (IGRP) configuration in Router03
Connect
to Router03 console and use the following IOS commands to configure Interior
Gateway Routing Protocol (IGRP) in Router03. Please refer the beginning of this
lesson to view the Interior Gateway Routing Protocol (IGRP) configuration IOS
command.
In
the IOS "network" command, shown below, we specify only the directly
connected networks of this router.
Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)# router igrp 1
Router03(config-router)# network 172.19.0.0
Router03(config-router)# network 172.20.0.0
Router03(config-router)#exit
Router03(config)#exit
Router03#
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
How to view the routing table in Router01
After
the network is converged after the initial configuration and Interior Gateway
Routing Protocol (IGRP) configuration, we can use the "show ip route"
to view the routing table in Router01, as shown below.
Router01>enable
Router01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 172.16.0.0/16 is directly connected, FastEthernet0/0
C 172.17.0.0/16 is directly connected, Serial0/0
I 172.18.0.0/16 [120/1] via 172.17.0.2, 00:00:22, Serial0/0
I 172.19.0.0/16 [120/1] via 172.17.0.2, 00:00:22, Serial0/0
I 172.20.0.0/16 [120/2] via 172.17.0.2, 00:00:22, Serial0/0
The
"I" character at the beginning of a line in routing table shows that
it is a route discovered byInterior Gateway Routing Protocol (IGRP) and
"C" character shows that it is a directly connected network.
How to view the routing table in Router02
When
the network is converged after the initial configuration and Interior Gateway
Routing Protocol (IGRP) configuration, we can use the "show ip route"
to view the routing table in Router02, as shown below.
Router02>enable
Router02#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
I 172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:07, Serial0/0
C 172.17.0.0/16 is directly connected, Serial0/0
C 172.18.0.0/16 is directly connected, FastEthernet0/0
C 172.19.0.0/16 is directly connected, Serial0/1
I 172.20.0.0/16 [120/1] via 172.19.0.2, 00:00:20, Serial0/1
The
"I" character at the beginning of a line in routing table shows that
it is a route discovered by Interior Gateway Routing Protocol (IGRP) and
"C" character shows that it is a directly connected network.
How to view the routing table in Router03
When
the network is converged after the initial configuration and Interior Gateway
Routing Protocol (IGRP) configuration, we can use the "show ip route"
to view the routing table in Router03, as shown below.
Router03>enable
Router03#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
I 172.16.0.0/16 [120/2] via 172.19.0.1, 00:00:02, Serial0/1
I 172.17.0.0/16 [120/1] via 172.19.0.1, 00:00:02, Serial0/1
I 172.18.0.0/16 [120/1] via 172.19.0.1, 00:00:02, Serial0/1
C 172.19.0.0/16 is directly connected, Serial0/1
C 172.20.0.0/16 is directly connected, FastEthernet0/0
The
"I" character at the beginning of a line in routing table shows that
it is a route discovered by Interior Gateway Routing Protocol (IGRP) and
"C" character shows that it is a directly connected network.
Verify the connectivity between networks using the ping command
To
verify the Interior Gateway Routing Protocol (IGRP) routes and the connectivity
between networks, run the ping command from Host01 (IP address: 172.16.0.10/16)
to Host03 (IP address: 172.20.0.10/16).
C:\>ping 172.20.0.10
Pinging 172.20.0.10 with 32 bytes of data:
Reply from 172.20.0.10: bytes=32 time=172ms TTL=125
Reply from 172.20.0.10: bytes=32 time=188ms TTL=125
Reply from 172.20.0.10: bytes=32 time=157ms TTL=125
Reply from 172.20.0.10: bytes=32 time=188ms TTL=125
Ping statistics for 172.20.0.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 157ms, Maximum = 188ms, Average = 176ms
The
ping reply from Host03 (IP address: 172.20.0.10/16) shows that the Interior
Gateway Routing Protocol (IGRP) is configured well in three routers and there
is network connectivity between different networks
14.What is Routing Loop and how to avoid Routing Loop
A
routing loop is a serious network problem which happens when a data packet is
continually routed through the same routers over and over. The data packets
continue to be routed within the network in an endless circle. A routing loop
can have a catastrophic impact on a network, and in some cases, completely
disabling the network. Normally Routing Loop is a problem associated with
Distance Vector Protocols.
Routing
Loop can happen in large internetworks when a second topology change emerges
before the network is able to converge on the first change. Convergence is the
term used to describe the condition when all routers in an internetwork have
agreed on a common topology. Link state protocols tend to converge very
quickly, while distance vector protocols tend to converge slowly.
The
following methods are used to avoid Routing Loops.
Maximum hop Count
Maximum
hop count mechanism can be used to prevent Routing Loops. Distance Vector
protocols use the TTL (Time-to-Live) value in the IP datagram header to avoid
Routing Loops. When an IP datagram move from router to router, a router keeps
track of the hops in the TTL field in the IP datagram header. For each hop a
packet goes through, the packet’s TTL field is decremented by one. If this
value reaches 0, the packet is dropped by the router that decremented the value
from 1 to 0.
Split Horizon
A
split horizon is a routing configuration that stops a route from being
advertised back in the direction from which it came. Split Horizon mechanism
states that if a neighbouring router sends a route to a router, the receiving
router will not propagate this route back to the advertising router on the same
interface.
Route Poisoning
Route
Poisoning is another method for avoiding routing loops. When a router detects
that one of its connected routes has failed, the router will poison the route
by assigning an infinite metric to it.
Hold-down Timers
Hold-down
timer is another mechanism used to prevent bad routes from being restored and
propagated by mistake. When a route is placed in a hold-down state, routers
will neither advertise the route nor accept advertisements about it for a
specific interval called the hold-down period
15.Introduction to Link State Routing Protocols
Link
state protocols are based on Shortest Path First (SPF) algorithm to find the best
path to a destination. Shortest Path First (SPF) algorithm is also known as
Dijkstra algorithm, since it is conceptualized by Dijkstra. In Shortest Path
First (SPF) algorithm, whenever a link's state changes, a routing update called
a Link-State Advertisement (LSA) is exchanged between routers. When a
router receives an LSA routing update, the link-state algorithm is used to
recalculate the shortest path to affected destinations. Link-state
routing always try to maintain full networks topology by updating itself
incrementally whenever a change happen in network. Each router constructs a map
of the complete network. An example of Link State protocol is OSPF (Open
Shortest Path First).
Some
important terms related with Link State Routing Protocols
•
Link-state advertisements (LSAs) – A link-state advertisement (LSA) is a small
packet of routing information that is sent between routers.
•
Topological database – A topological database is a collection of information
gathered from LSAs.
•
SPF algorithm (Dijkstra algorithm) – The shortest path first (SPF) algorithm is
a calculation performed on the database resulting in the SPF tree.
•
Routing tables – A list of the known paths and interfaces.
Link
State Routing Protocols converge more quickly and they are less prone to
routing loops than Distance Vector algorithms. On the other hand, Link State
Routing Protocols require more CPU power and memory than distance vector
algorithms. Link State Protocols use a hierarchical structure that limits the
distance that a Link-State Advertisement (LSA) need to travel. Link State
Protocols use multicasts to share the routing information. Only the routers
which run Link State protocol only process the updates. Link State routers send
updates only when there is a change in the state of the network (incremental
updates).
Link-state
algorithms can be more complex and expensive to implement and support.
16.Introduction to Open Shortest Path First (OSPF) Protocol
The
Open Shortest Path First (OSPF) protocol is a link state protocol that handles
routing for IP traffic. Its newest implementation, version 2, which is
explained in RFC 2328, is an open standard. Open Shortest Path First (OSPF) is
an open standard (not proprietary) and it will run on most routers independent
of make. Open Shortest Path First (OSPF) uses the Shortest Path First (SPF)
algorithm, developed by Dijkstra, to provide a loop-free topology. Open
Shortest Path First (OSPF) provides fast convergence with triggered,
incremental updates via Link State Advertisements (LSAs). Open Shortest Path
First (OSPF) is a classless protocol and allows for a hierarchical design with
VLSM and route summarization
The
main disadvantages of Open Shortest Path First (OSPF) are Open Shortest Path
First (OSPF) requires more memory to hold the adjacency (list of OSPF
neighbors), topology (a link state database containing all of the routers and
their routes), and routing tables, Open Shortest Path First (OSPF) requires
extra CPU processing to run the SPF algorithm and Open Shortest Path First
(OSPF) is a complex routing protocol.
The
two important concepts in case of OSPF are Autonomous Systems and Areas. Areas
are used to provide hierarchical routing, within an Autonomous System. Areas
are used to control when and how much routing information is shared across your
network.
OSPF
implements a two-layer hierarchy: the backbone (Area 0) and areas off of the
backbone (Areas 1–65,535). Here the two different areas can summarize routing
information between them. Route summerization helps to compact the routing
tables. All areas should connect to Area 0 and all routers in an Area will have
the same topology table.
Open Shortest Path First (OSPF) metric value
Open
Shortest Path First (OSPF) uses cost as the value of metric and uses a
reference bandwidth of 100 Mbps for cost calculation. The formula to calculate
the cost is reference bandwidth divided by interface bandwidth. For example, in
the case of Ethernet, it is 100 Mbps / 10 Mbps = 10.
Important Terms related with Open Shortest Path First (OSPF)
Router ID
Each
router in an OSPF network needs a unique ID. The ID is used to provide a unique
identity to the OSPF router.
•
The highest IP address on its loopback interfaces (this is a logical interface
on a router)
•
The highest IP address on its active interfaces
What is a Loopback Interface
A
loopback interface is a logical, virtual interface on a router. By default, the
router doesn’t have any loopback interfaces, but they can easily be created.
These interfaces are treated as physical interfaces on a router and we can
assign ip addresses to them.
Router(Config)#int loopback 2
Router(Config-if)#ip address 200.0.0.10 255.255.255.0
Area border router (ABR)
An
Area border router (ABR) is a router that connects one or more OSPF areas to
the main backbone network. It is considered a member of all areas it is
connected to.
Internal router
An
Internal Router is a router that has only OSPF neighbour relationships with
routers in the same area.
Backbone router
Backbone
Routers are part of the OSPF backbone. This includes all area border routers
and also routers connecting different areas.
Designated Router (DR) and Backup Designated Router (BDR)
A
Designated Router (DR) is the router interface elected among all routers on a
network segment, and Backup designated (BDR) is a backup for the Designated
Router (DR). Designated Routers (DRs) are used for reducing network traffic by
providing a source for routing updates. The Designated Router (DR) maintains a
complete topology table of the network and sends the updates to the other
routers via multicast. All routers in an area will form a slave/master
relationship with the Designated Router (DR).
16.How to configure Open Shortest Path First (OSPF) Protocol
If
you are not familair with Open Shortest Path First (OSPF) Protocol click the
following link to view an introduction to Open Shortest Path First (OSPF)
Protocol.
Open Shortest Path First (OSPF) Protocol Configuration
Router(config)# router ospf process_ID
Router(config-router)# network network_id wildcard_mask area area_#
Note:
Process
id: A value in the range 1–65,535 identifies the OSPF Process ID. OSPF Process
ID is a unique number on this router that groups a series of OSPF configuration
commands under a specific running process.
Wildcard
Mask: The wildcard mask (wildcard_mask) given above is the inverse mask of the
subnet mask. A 0 octet in the wildcard mask indicates that the corresponding
octet in the network must match exactly. On the other hand, a 255 indicates
that you don’t care what the corresponding octet is in the network number. A
network and wildcard mask combination of 192.168.10.0 0.0.0.0 would match
192.168.10.0 only, and nothing else.
Area
Number: The area_# given above is the Area Number. Area Number can always be
zero (0) for small networks, but for larger networks, the Area Number need to
be properly planned as all routing updates must traverse Area 0.
Open Shortest Path First (OSPF) Protocol - Lab Practice
The
following diagram shows our lab setup. We have three routers, three switches
and three hosts connected as below. The host names, IP addresses and the
interfaces of the routers are shown in diagram. The IP addresses of the hosts
are also shown in the diagram.
If
you are not familiar with a router console connection, click the following link
to learn how to connect the serial port of your computer to router console
port.
Click
the following link to learn how to connect to the console port of the router if
there is no serial port in your computer.
Click
the following links to learn how to use HyperTerminal terminal emulator and
PuTTY terminal emulator to configure router.
Hostname and IP address configuration in Router01
Connect
to Router01 console and use the following IOS commands to configure host name
as Router01.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router01
Router01(config)#
Use
the following IOS commands to open the fast ethernet interface Fa0/0
configuration mode on Router01 and configure IP address as 172.16.0.1/16.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#interface fa0/0
Router01(config-if)#ip address 172.16.0.1 255.255.0.0
Router01(config-if)#no shutdown
Use
the following IOS commands to open the serial interface S0/0 configuration mode
on Router01 and configure IP address as 172.17.0.1/16. You have to set a clock
rate also using the "clock rate" command on S0/0 interface, since
this is the DCE side.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#interface s0/0
Router01(config-if)#clock rate 64000
Router01(config-if)#ip address 172.17.0.1 255.255.0.0
Router01(config-if)#no shutdown
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Hostname and IP address configuration in Router02
Connect
to Router02 console and use the following IOS commands to configure host name
as Router02.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router02
Router02(config)#
Use
the following IOS commands to open the fast ethernet interface Fa0/0
configuration mode on Router02 and configure IP address as 172.18.0.1/16.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface fa0/0
Router02(config-if)#ip address 172.18.0.1 255.255.0.0
Router02(config-if)#no shutdown
Use
the following IOS commands to open the serial interface S0/0 configuration mode
on Router02 and configure IP address as 172.17.0.2/16.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface s0/0
Router02(config-if)#ip address 172.17.0.2 255.255.0.0
Router02(config-if)#no shutdown
Use
the following IOS commands to open the serial interface S0/1 configuration mode
on Router02 and configure IP address as 172.19.0.1/16. You have to set a clock
rate also using the "clock rate" command on S0/1 interface, since
this is the DCE side.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface s0/1
Router02(config-if)#clock rate 64000
Router02(config-if)#ip address 172.19.0.1 255.255.0.0
Router02(config-if)#no shutdown
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Hostname and IP address configuration in Router03
Connect
to Router03 console and use the following IOS commands to configure host name
as Router03.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router03
Router03(config)#
Use
the following IOS commands to open the fast ethernet interface Fa0/0
configuration mode on Router03 and configure IP address as 172.20.0.1/16.
Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#interface fa0/0
Router03(config-if)#ip address 172.20.0.1 255.255.0.0
Router03(config-if)#no shutdown
Use
the following IOS commands to open the serial interface S0/1 configuration mode
on Router03 and configure IP address as 172.19.0.2/16.
Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#interface s0/1
Router03(config-if)#ip address 172.19.0.2 255.255.0.0
Router03(config-if)#no shutdown
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Open Shortest Path First (OSPF) Protocol configuration in Router01
Connect
to Router01 console and use the following IOS commands to configure Open
Shortest Path First (OSPF) Protocol in Router01. Please refer the beginning of
this lesson to view the Open Shortest Path First (OSPF) Protocol configuration
IOS commands.
Using
the IOS "network" command, as shown below, we specify only the
directly connected networks of this router.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#router ospf 1
Router01(config-router)#network 172.16.0.0 0.0.255.255 area 0
Router01(config-router)#network 172.17.0.0 0.0.255.255 area 0
Router01(config-router)#exit
Router01(config)#exit
Router01#
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Open Shortest Path First (OSPF) Protocol configuration in Router02
Connect
to Router02 console and use the following IOS commands to configure Open
Shortest Path First (OSPF) Protocol in Router02. Please refer the beginning of
this lesson to view the Open Shortest Path First (OSPF) Protocol configuration
IOS commands.
Using
the IOS "network" command, as shown below, we specify only the
directly connected networks of this router.
Router02>
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line.
End with CNTL/Z.
Router02(config)#router ospf 1
Router02(config-router)#network 172.17.0.0
0.0.255.255 area 0
Router02(config-router)#network 172.18.0.0
0.0.255.255 area 0
Router02(config-router)#network 172.19.0.0
0.0.255.255 area 0
Router02(config-router)#exit
Router02(config)#exit
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Open Shortest Path First (OSPF) Protocol configuration in Router03
Connect
to Router03 console and use the following IOS commands to configure Open
Shortest Path First (OSPF) Protocol in Router03. Please refer the beginning of
this lesson to view the Open Shortest Path First (OSPF) Protocol configuration
IOS commands.
Using
the IOS "network" command, as shown below, we specify only the
directly connected networks of this router.
Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#router ospf 1
Router03(config-router)#network 172.19.0.0 0.0.255.255 area 0
Router03(config-router)#network 172.20.0.0 0.0.255.255 area 0
Router03(config-router)#exit
Router03(config)#exit
Router03#
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
How to view the routing table in Router01
After
the initial configuration and Open Shortest Path First (OSPF) Protocol
configuration in all routers, we can use the "show ip route" to view
the routing table in Router01, as shown below.
Router01>enable
Router01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 172.16.0.0/16 is directly connected, FastEthernet0/0
C 172.17.0.0/16 is directly connected, Serial0/0
O 172.18.0.0/16 [110/65] via 172.17.0.2, 00:26:31, Serial0/0
O 172.19.0.0/16 [110/128] via 172.17.0.2, 00:26:21, Serial0/0
O 172.20.0.0/16 [110/129] via 172.17.0.2, 00:24:54, Serial0/0
The
"O" character at the beginning of a line in routing table shows that
it is a route discovered by Open Shortest Path First (OSPF) Protocol and
"C" character shows that it is a directly connected network.
How to view the routing table in Router02
After
the initial configuration and Open Shortest Path First (OSPF) Protocol
configuration in all routers, we can use the "show ip route" to view
the routing table in Router02, as shown below.
Router02>enable
Router02#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
O 172.16.0.0/16 [110/65] via 172.17.0.1, 00:30:20, Serial0/0
C 172.17.0.0/16 is directly connected, Serial0/0
C 172.18.0.0/16 is directly connected, FastEthernet0/0
C 172.19.0.0/16 is directly connected, Serial0/1
O 172.20.0.0/16 [110/65] via 172.19.0.2, 00:28:08, Serial0/1
The
"O" character at the beginning of a line in routing table shows that
it is a route discovered by Open Shortest Path First (OSPF) Protocol and
"C" character shows that it is a directly connected network.
How to view the routing table in Router03
After
the initial configuration and Open Shortest Path First (OSPF) Protocol
configuration in all routers, we can use the "show ip route" to view
the routing table in Router03, as shown below.
Router03>enable
Router03#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
O 172.16.0.0/16 [110/129] via 172.19.0.1, 00:29:43, Serial0/1
O 172.17.0.0/16 [110/128] via 172.19.0.1, 00:29:43, Serial0/1
O 172.18.0.0/16 [110/65] via 172.19.0.1, 00:29:43, Serial0/1
C 172.19.0.0/16 is directly connected, Serial0/1
C 172.20.0.0/16 is directly connected, FastEthernet0/0
The
"O" character at the beginning of a line in routing table shows that
it is a route discovered by Open Shortest Path First (OSPF) Protocol and
"C" character shows that it is a directly connected network.
Verify the connectivity between networks using the ping command
To
verify the Open Shortest Path First (OSPF) Protocol routes and the connectivity
between networks, run the ping command from Host01 (IP address: 172.16.0.10/16)
to Host03 (IP address: 172.20.0.10/16).
C:\>ping 172.20.0.10
Pinging 172.20.0.10 with 32 bytes of data:
Reply from 172.20.0.10: bytes=32 time=172ms TTL=125
Reply from 172.20.0.10: bytes=32 time=188ms TTL=125
Reply from 172.20.0.10: bytes=32 time=157ms TTL=125
Reply from 172.20.0.10: bytes=32 time=188ms TTL=125
Ping statistics for 172.20.0.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 157ms, Maximum = 188ms, Average = 176ms
The
ping reply from Host03 (IP address: 172.20.0.10/16) shows that the Open
Shortest Path First (OSPF) Protocol is configured well in three routers and
there is network connectivity between different networks.
18.Introduction to Hybrid Routing Protocols
A
hybrid protocol has the advantages of both distance vector and link state
protocols and merges them into a new protocol. Typically, hybrid protocols are
based on a distance vector protocol but contain many of the features and
advantages of link state protocols. Example: EIGRP (Enhanced Interior Gateway
Routing Protocol).
Enhanced
Interior Gateway Routing Protocol (EIGRP) is considered as a Hybrid Routing
Protocol because EIGRP has characteristics of both Distance Vector and Link
State Routing Protocols. Enhanced Interior Gateway Routing Protocol (EIGRP)
doesn’t send Link State Advertisement (LSA) packets as OSPF does, but Enhanced
Interior Gateway Routing Protocol (EIGRP) sends traditional Distance Vector
updates containing information about networks plus the cost of reaching them
from the perspective of the advertising router. Enhanced Interior Gateway
Routing Protocol (EIGRP) has link-state characteristics also. Enhanced Interior
Gateway Routing Protocol (EIGRP) synchronizes routing tables between neighbors
at startup, and then it sends specific updates when a network topology change
happen.
19.Introduction to Enhanced Interior Gateway Routing Protocol
(EIGRP)
Enhanced
Interior Gateway Routing Protocol (EIGRP) is a Cisco proprietary enhanced
Distance Vector routing protocol. EIGRP is based on IGRP, hence the
configuration is similar. Enhanced Interior Gateway Routing Protocol (EIGRP) is
considered as a Hybrid Routing Protocol because EIGRP has characteristics of
both Distance Vector and Link State Routing Protocols. Both EIGRP and IGRP
offer load balancing across six paths (equal or unequal), and they have similar
metric structures. EIGRP has faster convergence, and has less network overhead,
since it uses incremental updates. Another important features of Enhanced
Interior Gateway Routing Protocol (EIGRP) are routing loop-free topology, VLSM
and route summarization, multicast and incremental updates and routes for
multiple routed protocols (IP, IPX and AppleTalk)
Enhanced
Interior Gateway Routing Protocol (EIGRP) Uses Diffused Update Algorithm (DUAL)
to calculate the shortest path.
The following formula is used to calculate the metric of Enhanced Interior
Gateway Routing Protocol (EIGRP).
Metric
= [K1*Bandwidth + (K2*Bandwidth)/ (256 - Load) + K3*Delay] * [K5/(Reliability +
K4)]
The
default values for K are K1 = 1, K2 = 0, K3 = 1, K4 = 0, K5 = 0. For default
behaviour, the formula can be simplified as metric = bandwidth + delay
Important terms related with Enhanced Interior Gateway Routing
Protocol (EIGRP)
DUAL
DUAL
stands for Diffused Update Algorithm, the algorithm used by Enhanced Interior
Gateway Routing Protocol (EIGRP) to calculate the shortest path.
Neighbor table
Neighbor
table contains a list of the EIGRP neighbours. Each routed protocol for EIGRP
has its own neighbour table.
Topology table
Topology
table contains a list of all destinations and paths the EIGRP router learned. There
is a separate topology table for each routed protocol.
Successor
Successor
is the best path to reach a destination within the topology table.
Feasible successor
Feasible
successor is the best backup path to reach a destination
Routing table
Routing
table contains all of the successor routes from the topology table. There is a
separate routing table for each routed protocol.
Advertised distance
Advertised
distance is the distance (metric) that a neighbouring router is advertising for
a specific route.
Feasible distance
Feasible
distance is the distance (metric) that your router will use to reach a specific
route.
20.How to configure Enhanced Interior Gateway Routing Protocol
(EIGRP)
If
you are not familiar with Enhanced Interior Gateway Routing Protocol (EIGRP),
click the following link to view an introduction to Enhanced Interior Gateway
Routing Protocol (EIGRP).
Enhanced Interior Gateway Routing Protocol (EIGRP) Configuration
Enhanced
Interior Gateway Routing Protocol (EIGRP) can be configured in a router using
the following IOS commands.
Router(config)# router eigrp ASN
Router(config-router)# network Network_ID
ASN in the above IOS command stands for Autonomous System Number.
Enhanced Interior Gateway Routing Protocol (EIGRP) - Lab Practice
The
following diagram shows our lab setup. We have three routers, three switches
and three hosts connected as below. The host names, IP addresses and the
interfaces of the routers are shown in diagram. The IP addresses of the hosts
are also shown in the diagram.
If
you are not familiar with a router console connection, click the following link
to learn how to connect the serial port of your computer to router console
port.
Click
the following link to learn how to connect to the console port of the router if
there is no serial port in your computer.
Click
the following links to learn how to use HyperTerminal terminal emulator and
PuTTY terminal emulator to configure router.
Hostname and IP address configuration in Router01
Connect
to Router01 console and use the following IOS commands to configure host name
as Router01.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router01
Router01(config)#
Use
the following IOS commands to open the fast ethernet interface Fa0/0
configuration mode on Router01 and configure IP address as 172.16.0.1/16.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#interface fa0/0
Router01(config-if)#ip address 172.16.0.1 255.255.0.0
Router01(config-if)#no shutdown
Use
the following IOS commands to open the serial interface S0/0 configuration mode
on Router01 and configure IP address as 172.17.0.1/16. You have to set a clock
rate also using the "clock rate" command on S0/0 interface, since
this is the DCE side.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#interface s0/0
Router01(config-if)#clock rate 64000
Router01(config-if)#ip address 172.17.0.1 255.255.0.0
Router01(config-if)#no shutdown
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Hostname and IP address configuration in Router02
Connect
to Router02 console and use the following IOS commands to configure host name
as Router02.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router02
Router02(config)#
Use
the following IOS commands to open the fast ethernet interface Fa0/0
configuration mode on Router02 and configure IP address as 172.18.0.1/16.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface fa0/0
Router02(config-if)#ip address 172.18.0.1 255.255.0.0
Router02(config-if)#no shutdown
Use
the following IOS commands to open the serial interface S0/0 configuration mode
on Router02 and configure IP address as 172.17.0.2/16.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface s0/0
Router02(config-if)#ip address 172.17.0.2 255.255.0.0
Router02(config-if)#no shutdown
Use
the following IOS commands to open the serial interface S0/1 configuration mode
on Router02 and configure IP address as 172.19.0.1/16. You have to set a clock
rate also using the "clock rate" command on S0/1 interface, since
this is the DCE side.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface s0/1
Router02(config-if)#clock rate 64000
Router02(config-if)#ip address 172.19.0.1 255.255.0.0
Router02(config-if)#no shutdown
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Hostname and IP address configuration in Router03
Connect
to Router03 console and use the following IOS commands to configure host name
as Router03.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router03
Router03(config)#
Use
the following IOS commands to open the fast ethernet interface Fa0/0 configuration
mode on Router03 and configure IP address as 172.20.0.1/16.
Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#interface fa0/0
Router03(config-if)#ip address 172.20.0.1 255.255.0.0
Router03(config-if)#no shutdown
Use
the following IOS commands to open the serial interface S0/1 configuration mode
on Router03 and configure IP address as 172.19.0.2/16.
Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#interface s0/1
Router03(config-if)#ip address 172.19.0.2 255.255.0.0
Router03(config-if)#no shutdown
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Enhanced Interior Gateway Routing Protocol (EIGRP) configuration
in Router01
Connect
to Router01 console and use the following IOS commands to configure Enhanced
Interior Gateway Routing Protocol (EIGRP) in Router01. Please refer the
beginning of this lesson to view the Enhanced Interior Gateway Routing Protocol
(EIGRP) configuration IOS command.
In
the IOS "network" command, shown below, we specify only the directly
connected networks of this router.
Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#router eigrp 1
Router01(config-router)#network 172.16.0.0
Router01(config-router)#network 172.17.0.0
Router01(config-router)#exit
Router01(config)#exit
Router01#
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Enhanced Interior Gateway Routing Protocol (EIGRP) configuration
in Router02
Connect
to Router02 console and use the following IOS commands to configure Enhanced
Interior Gateway Routing Protocol (EIGRP) in Router02. Please refer the
beginning of this lesson to view the Enhanced Interior Gateway Routing Protocol
(EIGRP) configuration IOS command.
In
the IOS "network" command, shown below, we specify only the directly
connected networks of this router.
Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#router eigrp 1
Router02(config-router)#network 172.17.0.0
Router02(config-router)#network 172.18.0.0
Router02(config-router)#network 172.19.0.0
Router02(config-router)#exit
Router02(config)#exit
Router02#
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
Enhanced Interior Gateway Routing Protocol (EIGRP) configuration
in Router03
Connect
to Router03 console and use the following IOS commands to configure Enhanced
Interior Gateway Routing Protocol (EIGRP) in Router03. Please refer the
beginning of this lesson to view the Enhanced Interior Gateway Routing Protocol
(EIGRP) configuration IOS command.
In
the IOS "network" command, shown below, we specify only the directly
connected networks of this router.
Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#router eigrp 1
Router03(config-router)#network 172.19.0.0
Router03(config-router)#network 172.20.0.0
Router03(config-router)#exit
Router03(config)#exit
Router03#
Do
remember to run the "copy running-config startup-config" command from
enable mode, if you want to save the changes you have made in the router.
How to view the routing table in Router01
After
the initial configuration and Enhanced Interior Gateway Routing Protocol
(EIGRP) configuration in all routers, we can use the "show ip route"
to view the routing table in Router01, as shown below.
Router01>enable
Router01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 172.16.0.0/16 is directly connected, FastEthernet0/0
C 172.17.0.0/16 is directly connected, Serial0/0
D 172.18.0.0/16 [90/2172416] via 172.17.0.2, 00:05:36, Serial0/0
D 172.19.0.0/16 [90/2681856] via 172.17.0.2, 00:05:30, Serial0/0
D 172.20.0.0/16 [90/2684416] via 172.17.0.2, 00:02:35, Serial0/0
The
"D" character at the beginning of a line in routing table shows that
it is a route discovered by Enhanced Interior Gateway Routing Protocol (EIGRP)
and "C" character shows that it is a directly connected network.
How to view the routing table in Router02
After
the initial configuration and Enhanced Interior Gateway Routing Protocol
(EIGRP) configuration in all routers, we can use the "show ip route"
to view the routing table in Router02, as shown below.
Router02>enable
Router02#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
D 172.16.0.0/16 [90/2172416] via 172.17.0.1, 00:08:02, Serial0/0
C 172.17.0.0/16 is directly connected, Serial0/0
C 172.18.0.0/16 is directly connected, FastEthernet0/0
C 172.19.0.0/16 is directly connected, Serial0/1
D 172.20.0.0/16 [90/2172416] via 172.19.0.2, 00:04:45, Serial0/1
The
"D" character at the beginning of a line in routing table shows that
it is a route discovered by Enhanced Interior Gateway Routing Protocol (EIGRP)
and "C" character shows that it is a directly connected network.
How to view the routing table in Router03
After
the initial configuration and Enhanced Interior Gateway Routing Protocol
(EIGRP) configuration in all routers, we can use the "show ip route"
to view the routing table in Router03, as shown below.
Router03>enable
Router03#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
D 172.16.0.0/16 [90/2684416] via 172.19.0.1, 00:06:01, Serial0/1
D 172.17.0.0/16 [90/2681856] via 172.19.0.1, 00:06:01, Serial0/1
D 172.18.0.0/16 [90/2172416] via 172.19.0.1, 00:06:01, Serial0/1
C 172.19.0.0/16 is directly connected, Serial0/1
C 172.20.0.0/16 is directly connected, FastEthernet0/0
The
"D" character at the beginning of a line in routing table shows that
it is a route discovered by Enhanced Interior Gateway Routing Protocol (EIGRP)
and "C" character shows that it is a directly connected network.
Verify the connectivity between networks using the ping command
To
verify the Enhanced Interior Gateway Routing Protocol (EIGRP) routes and the
connectivity between networks, run the ping command from Host01 (IP address:
172.16.0.10/16) to Host03 (IP address: 172.20.0.10/16).
C:\>ping 172.20.0.10
Pinging 172.20.0.10 with 32 bytes of data:
Reply from 172.20.0.10: bytes=32 time=172ms TTL=125
Reply from 172.20.0.10: bytes=32 time=188ms TTL=125
Reply from 172.20.0.10: bytes=32 time=157ms TTL=125
Reply from 172.20.0.10: bytes=32 time=188ms TTL=125
Ping statistics for 172.20.0.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 157ms, Maximum = 188ms, Average = 176ms
The
ping reply from Host03 (IP address: 172.20.0.10/16) shows that the Enhanced
Interior Gateway Routing Protocol (EIGRP) Protocol is configured well in three
routers and there is network connectivity between different networks.